Jump to content


No sound effects

No sound effects

10 replies to this topic

#1 Irrediate

    Newbie

  • Members
  • Pip
  • 2 posts
  • 1 topics
  • Local Time: Jul 21 2017 19:38

    Posted 30 January 2013 - 22:54

    Hello!

    After getting the game to work and i started playing, i immediatly noticed the lack of sound effects. there is music however.
    I remember playing this game as a kid and finding some of the sounds to be just awesome! And i wanna have those back.

    Any clue on how to fix this?

    #2 DAroo

      Guru

    • Administrators
    • 1276 posts
    • 70 topics
  • Local Time: Jul 21 2017 20:38
    • LocationPoland

    Posted 31 January 2013 - 20:03

    Music works for you, so it sounds like a problem with settings of a game. Go to options > sound and play with bars there.
    Posted Image

    #3 Irrediate

      Newbie

    • Members
    • Pip
    • 2 posts
    • 1 topics
  • Local Time: Jul 21 2017 19:38

    Posted 31 January 2013 - 20:55

    Those are all fine. There is no sound anywhere other then the music. No voices, no spells, no construction or anything.

    #4 DAroo

      Guru

    • Administrators
    • 1276 posts
    • 70 topics
  • Local Time: Jul 21 2017 20:38
    • LocationPoland

    Posted 01 February 2013 - 20:25

    o.0

    It must be one of those random problems with a game, which nobody has any clue about how to fix, and sometimes they get fixed magically by itself. You might try to activate some sound effects in a control panel if you have such panel included to your windows. You can try to download and install a version from popms or popre.
    Posted Image

    #5 rakuten

      Newbie

    • Members
    • Pip
    • 1 posts
    • 0 topics
  • Local Time: Jul 21 2017 10:38

    Posted 18 July 2013 - 00:50

    I was having this exact same issue in Windows 7 - could hear the music just fine, but no sound effects, even though they were labeled as 'on' in the options menu.

    Figured it out though! If you toggle the Sound Quality from High to Low, the sound effects will work just fine - I think the original problem happens because the high-quality sounds were eliminated from the download to save space.

    Hope this helps anyone else out there who's run into this problem!

    #6 DAroo

      Guru

    • Administrators
    • 1276 posts
    • 70 topics
  • Local Time: Jul 21 2017 20:38
    • LocationPoland

    Posted 18 July 2013 - 18:54

    Nice catch! Thanks! I need to tweak the installer to activate low quality of the sound by default.
    Posted Image

    #7 DAroo

      Guru

    • Administrators
    • 1276 posts
    • 70 topics
  • Local Time: Jul 21 2017 20:38
    • LocationPoland

    Posted 30 July 2013 - 15:20

    I uploaded the new version of the installer to the website. It should be fixed now.
    Posted Image

    #8 Nici

      User

    • Members
    • PipPipPipPip
    • 59 posts
    • 4 topics
  • Local Time: Jul 21 2017 19:38
    • LocationOurém, Portugal

    Posted 30 July 2013 - 17:13

    Thanks! :)
    My raidcall username is franciscobaph, add me

    skype: franciscoabaptistahenriques

    pass by ava n apply

    #9 KevO

      Newbie

    • Members
    • Pip
    • 1 posts
    • 0 topics
  • Local Time: Jul 21 2017 19:38

    Posted 16 August 2016 - 14:55

    How to replace the files then, so I can have those sounds back in the game? Or what do I do for that?

    #10 DAroo

      Guru

    • Administrators
    • 1276 posts
    • 70 topics
  • Local Time: Jul 21 2017 20:38
    • LocationPoland

    Posted 17 August 2016 - 08:29

    To restore high quality sounds you need to download a file: high_quality_music_file

    Place it inside the "Sound" directory of the populous installation (usually "C:\Program Files (x86)\Bullfrog\Populous\Sound" )

    And then enable it in the options of the game
    Posted Image

    #11 Int3rtranslaten

      Newbie

    • Members
    • Pip
    • 1 posts
    • 0 topics
  • Local Time: Jul 21 2017 10:38

    Posted 25 January 2017 - 10:52

    Had the same problem, thank you for helping me as well!





    2 user(s) are reading this topic